277 lines
7.2 KiB
Nix
277 lines
7.2 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page, on
|
||
# https://search.nixos.org/options and in the NixOS manual (`nixos-help`).
|
||
|
||
{ config, lib, pkgs, ... }:
|
||
|
||
{
|
||
imports =
|
||
[ # Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
#inputs.home-manager.nisosModules.home-manager
|
||
#(import "${builtins.fetchTarball https://github.com/rycee/home-manager/archive/master.tar.gz}/nixos")
|
||
#/../home-manager/home.nix
|
||
];
|
||
|
||
|
||
nix.settings.experimental-features = [ "nix-command" "flakes" ];
|
||
|
||
nixpkgs.config.allowUnfree = true;
|
||
|
||
# home-manager = {
|
||
# extraSpecialArgs = { inherit inputs outputs; };
|
||
# users = {
|
||
#
|
||
# };
|
||
# };
|
||
|
||
# Use the systemd-boot EFI boot loader.
|
||
boot.loader.systemd-boot.enable = true;
|
||
boot.loader.efi.canTouchEfiVariables = true;
|
||
|
||
networking.hostName = "nixoslaptop"; # Define your hostname.
|
||
# Pick only one of the below networking options.
|
||
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
|
||
networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "America/Chicago";
|
||
|
||
# Configure network proxy if necessary
|
||
# networking.proxy.default = "http://user:password@proxy:port/";
|
||
# networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
|
||
|
||
# Select internationalisation properties.
|
||
i18n.defaultLocale = "en_US.UTF-8";
|
||
console = {
|
||
font = "Lat2-Terminus16";
|
||
#keyMap = "us";
|
||
useXkbConfig = true; # use xkb.options in tty.
|
||
};
|
||
|
||
# Enable the X11 windowing system.
|
||
services.xserver.enable = true;
|
||
services.xserver.displayManager.defaultSession = "bspwm";
|
||
services.xserver.desktopManager.session =
|
||
[ {
|
||
manage = "desktop";
|
||
name = "bspwm";
|
||
start = ''
|
||
${pkgs.bspwm}/bin/bspwm &
|
||
waitPID=$!
|
||
'';
|
||
}
|
||
];
|
||
|
||
|
||
|
||
# Configure keymap in X11
|
||
services.xserver.xkb.layout = "us";
|
||
# services.xserver.xkb.options = "eurosign:e,caps:escape";
|
||
|
||
# Enable CUPS to print documents.
|
||
services.printing.enable = true;
|
||
|
||
# Enable sound.
|
||
sound.enable = true;
|
||
hardware.pulseaudio.enable = true;
|
||
|
||
# Enable touchpad support (enabled default in most desktopManager).
|
||
services.xserver.libinput.enable = true;
|
||
|
||
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
users.users.kaitlynn = {
|
||
isNormalUser = true;
|
||
extraGroups = [ "wheel" "libvirtd" ]; # Enable ‘sudo’ for the user.
|
||
packages = with pkgs; [
|
||
firefox
|
||
tree
|
||
bspwm
|
||
sxhkd
|
||
xfce.xfce4-terminal
|
||
xfce.xfconf
|
||
dmenu
|
||
polybarFull
|
||
picom-allusive
|
||
r2modman
|
||
vesktop
|
||
spotify
|
||
prismlauncher
|
||
gscreenshot
|
||
];
|
||
};
|
||
|
||
# List packages installed in system profile. To search, run:
|
||
# $ nix search wget
|
||
environment.systemPackages = with pkgs; [
|
||
vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
|
||
nano
|
||
wget
|
||
git
|
||
lshw
|
||
vulkan-tools
|
||
vkmark
|
||
mesa
|
||
nvtop
|
||
pavucontrol
|
||
gpsd
|
||
gdal
|
||
python311Full
|
||
python311Packages.pip
|
||
usbutils
|
||
pciutils
|
||
gcc
|
||
libgcc
|
||
zlib
|
||
nix-index
|
||
screen
|
||
putty
|
||
psmisc
|
||
spice
|
||
spice-gtk
|
||
spice-protocol
|
||
virt-viewer
|
||
virtio-win
|
||
win-spice
|
||
home-manager
|
||
];
|
||
|
||
programs.nix-ld.enable = true;
|
||
programs.nix-ld.libraries = with pkgs; [
|
||
zlib # numpy
|
||
libgcc # sqlalchemy
|
||
# that's where the shared libs go, you can find which one you need using
|
||
# nix-locate --top-level libstdc++.so.6 (replace this with your lib)
|
||
# ^ this requires `nix-index` pkg
|
||
];
|
||
|
||
# Virtualization
|
||
virtualisation = {
|
||
libvirtd = {
|
||
enable = true;
|
||
qemu = {
|
||
package = pkgs.qemu_kvm;
|
||
swtpm.enable = true;
|
||
ovmf.enable = true;
|
||
ovmf.packages = [ pkgs.OVMFFull.fd ];
|
||
};
|
||
};
|
||
spiceUSBRedirection.enable = true;
|
||
};
|
||
|
||
programs.virt-manager.enable = true;
|
||
|
||
#home-manager.users.kaitlynn = {
|
||
# dconf.settings = {
|
||
# "org/virt-manager/virt-manager/connections" = {
|
||
# autoconnect = [ "qemu:///system" ];
|
||
# uris = [ "qemu:///system" ];
|
||
# };
|
||
# };
|
||
#};
|
||
#}
|
||
|
||
services.gpsd = {
|
||
enable = true;
|
||
devices = [ "/dev/rfcomm0" ];
|
||
};
|
||
|
||
# Bluetooth stuff
|
||
hardware.bluetooth = {
|
||
enable = true; # enables support for Bluetooth
|
||
powerOnBoot = true; # powers up the default Bluetooth controller on boot
|
||
settings.General = {
|
||
#Enable =
|
||
ControllerMode = "bredr";
|
||
#FastConnectable = "true";
|
||
Experimental = "true";
|
||
KernelExperimental = "true";
|
||
};
|
||
};
|
||
services.blueman.enable = true;
|
||
|
||
programs.steam.enable = true;
|
||
|
||
nixpkgs.config.permittedInsecurePackages = [
|
||
"electron-25.9.0" # EOL, but is required by r2modman
|
||
];
|
||
|
||
|
||
# Some programs need SUID wrappers, can be configured further or are
|
||
# started in user sessions.
|
||
programs.mtr.enable = true;
|
||
programs.gnupg.agent = {
|
||
enable = true;
|
||
enableSSHSupport = true;
|
||
};
|
||
|
||
# List services that you want to enable:
|
||
|
||
# Enable the OpenSSH daemon.
|
||
services.openssh.enable = true;
|
||
|
||
# Open ports in the firewall.
|
||
# networking.firewall.allowedTCPPorts = [ ... ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
networking.firewall.enable = false;
|
||
|
||
# Nvidia Drivers
|
||
hardware.opengl = {
|
||
enable = true;
|
||
driSupport = true;
|
||
driSupport32Bit = true;
|
||
};
|
||
|
||
services.xserver.videoDrivers = ["nvidia"];
|
||
|
||
hardware.nvidia = {
|
||
modesetting.enable = true;
|
||
|
||
powerManagement.enable = false;
|
||
|
||
powerManagement.finegrained = false;
|
||
|
||
open = false;
|
||
|
||
nvidiaSettings = true;
|
||
|
||
package = config.boot.kernelPackages.nvidiaPackages.stable;
|
||
|
||
prime = {
|
||
#offload = {
|
||
# enable = true;
|
||
# enableOffloadCmd = true;
|
||
#};
|
||
sync.enable = true;
|
||
amdgpuBusId = "PCI:6:0:0";
|
||
nvidiaBusId = "PCI:1:0:0";
|
||
};
|
||
};
|
||
|
||
# Copy the NixOS configuration file and link it from the resulting system
|
||
# (/run/current-system/configuration.nix). This is useful in case you
|
||
# accidentally delete configuration.nix.
|
||
# system.copySystemConfiguration = true;
|
||
|
||
# This option defines the first version of NixOS you have installed on this particular machine,
|
||
# and is used to maintain compatibility with application data (e.g. databases) created on older NixOS versions.
|
||
#
|
||
# Most users should NEVER change this value after the initial install, for any reason,
|
||
# even if you've upgraded your system to a new NixOS release.
|
||
#
|
||
# This value does NOT affect the Nixpkgs version your packages and OS are pulled from,
|
||
# so changing it will NOT upgrade your system.
|
||
#
|
||
# This value being lower than the current NixOS release does NOT mean your system is
|
||
# out of date, out of support, or vulnerable.
|
||
#
|
||
# Do NOT change this value unless you have manually inspected all the changes it would make to your configuration,
|
||
# and migrated your data accordingly.
|
||
#
|
||
# For more information, see `man configuration.nix` or https://nixos.org/manual/nixos/stable/options#opt-system.stateVersion .
|
||
system.stateVersion = "23.11"; # Did you read the comment?
|
||
|
||
}
|
||
|